PICmicro multiprogrammer EB006V9

Support-Forum für Deutschsprachige, die in ihrer Muttersprache schreiben möchten.

Moderator: Benj

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

PICmicro multiprogrammer EB006V9

Postby TFreund » Sun Mar 13, 2016 11:15 pm

Hallo,
ich habe ein Problem seit ich einen neuen PC habe mit Windows 10 64 Bit mit den PICmicro multiprogrammer EB006V9
im Geräte Manager wird er richtig erkannt siehe Bild 1
Aber das Programm mLoader findet den PICmicro multiprogrammer nicht siehe Bild 2
Was könnte das Problem sein?
Auf meinen alten PC unter Windows 7 64 Bit hatte ich keine Probleme mit den Komponenten.
Gruß
Thomas
Attachments
Bilder.jpg
(74.91 KiB) Downloaded 5415 times

User avatar
Benj
Matrix Staff
Posts: 12979
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3740 times
Been thanked: 3595 times
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby Benj » Mon Mar 14, 2016 11:29 am

Hallo Thomas,

Sie könnten versuchen, die aktuelle Gerätetreiber zu deinstallieren und versuchen, von hier auf der offiziellen Treiber installieren.

http://www.matrixtsl.com/resources/getr ... php?id=744

Sie könnten aus dem Internet trennen müssen , sobald Sie den Treiber heruntergeladen haben, werden Sie den Treiber von Windows-Update zu verhindern automatisch installiert.

Wenn das nicht funktioniert, dann , welche Version der mLoader Software verwenden Sie?



Hello Thomas,

You could try uninstalling the current device driver and try installing the official driver from here.

http://www.matrixtsl.com/resources/getr ... php?id=744

You might need to disconnect from the internet once you have downloaded the driver to prevent the driver from Windows update being automatically installed.

If this doesn't work then what version of the mLoader software are you using?

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Mon Mar 14, 2016 5:52 pm

Hallo,
ich habe das alles schon gemacht aber es hat nichts gebracht.
Ich verwende folgende Softwareversionen und Hardware .

mLoader Version 3.3.0.9
Treiberversion 1.0.0.5 Treiberdatum 06.01.2015 für multiprogrammer EB006V9
Flowcode V6.1.3.2 (18.02.2016) Professional-Version ( PIC/ AVR / dsPIC/PIC24 )
außer dem erkennt die Software auch alle andern Programmer nicht
dsPIC/PIC24 Multiprogrammer EB064
PICmicro multiprogrammer Vorgänger Version
und die ECIO Module ( 28 pin PIC 18 ECIO, 40 pin PIC 18 ECIO und 40 pin dsPIC 33 ECIO )
ich habe für alle die Aktuellen Treiber installiert.
Im Geräte Manager wird alles Richtig erkannt.

Was Funktioniert:
Der Vorgänger PICmicro multiprogrammer wir von der Alten Software ( PPPv3 ) erkannt und Funktioniert auch in vollem umfang.
Was auch noch Funktioniert sind noch Arduino Entwicklungsboard alle 4 Arduino typen die ich benutze können Programmiert werden.

Unter Win7 hat alles Funktioniert ohne Probleme!!
jetzt habe ich ein großes ( sehr großes ) Problem!!!

Was könnte es jetzt noch sein?

Gruß
Thomas

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Thu Mar 17, 2016 11:44 pm

Hallo,

ich wollte mal nachfragen gibt’s es für dieses Problem jetzt eine Lösung ja oder nein oder Arbeiten sie noch an einer Lösung?

gruß

Thomas

User avatar
Benj
Matrix Staff
Posts: 12979
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3740 times
Been thanked: 3595 times
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby Benj » Fri Mar 18, 2016 11:06 am

Hallo Thomas,

Entschuldigung für die Verspätung. Wir sind nicht in der Lage , das Problem hier zu replizieren. Haben Sie etwas anderes eingesteckt haben , dass Sie zu entfernen versuchen , um zu sehen , ob das hilft . Außerdem laufen Sie eine Firewall oder Antiviren-Software , die möglicherweise blockieren Dinge sein könnte?


Hello Thomas,

Sorry for the delay. We are unable to replicate the problem here. Do you have anything else plugged in that you can try removing to see if that helps. Also are you running any firewall or antivirus software that could potentially be blocking things?

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Fri Mar 18, 2016 8:15 pm

Hallo,

ich habe jetzt mal das Antivirus Programm ( MaAfee ) gelöscht und die Firewall abgestellt aber das hat nichts gebracht es geht immer noch nicht.

Was mir aufgefallen ist das im Verzeichnis von mLoader eine Alte Version von winusb.dll ( Größe 17KB )
vorhanden ist aber im Windows Verzeichnis eine Neuere Version vorhanden sind von winusb.dll ( Größe 21KB/26KB )
kann das vielleicht das Problem sein.

Kommt das Programm mLoader vielleicht nicht mit der Neueren Version zurechtkommt?

Gruß
Thomas

User avatar
Benj
Matrix Staff
Posts: 12979
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3740 times
Been thanked: 3595 times
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby Benj » Mon Mar 21, 2016 3:35 pm

Hallo Thomas,

Die DLL sollte als mLoader EXE im selben Ordner sein . Dies zwingt sie die richtige DLL zu verwenden. Sie könnten versuchen, die neueste DLL in das mLoader Verzeichnis kopieren und sehen, ob diese besser funktionieren, aber ich denke, das Problem ist anders als wir nicht andere mit dem gleichen Problem haben.

Ein weiterer Trick könnte sein, um Dependency Walker auf mLoader laufen und sehen , was Windows denkt fehlt.

Etwas anderes, ich habe, ist die Windows- Smartscreen gesehen - dies könnte möglicherweise es blockiert sein .

Ich würde auch an den DEP -Einstellungen wie folgt aussehen möglicherweise mit ihm stören könnten , aber dies in der Regel hält nur die App aus überhaupt ausgeführt wird (obwohl ich die DLL vermuten könnte irgendwie mit DEP oder Smartscreen blockiert werden ) .

Gibt es noch etwas speziell für Ihre Maschine, die stören könnte . Wir haben viele Tests mit Windows- 10 durchgeführt und keine Fragen wie diese gesehen .



Hello Thomas,

The DLL should be in the same folder as the mLoader EXE. This forces it to use the correct DLL. You could try copying the latest DLL to the mLoader directory and see if these work any better, but I guess the problem is different as we’re not having others with the same issue.

Another trick could be to run dependency walker on mLoader and see what Windows thinks is missing.

Something else I’ve seen is the Windows SmartScreen – this could be potentially blocking it.

I’d also potentially look at the DEP settings as this could interfere with it, but this usually just stops the app from running at all (although I suppose the DLL might be somehow blocked with DEP or SmartScreen).

Is there anything else specific to your machine that could be interfering. We have done lots of testing with Windows 10 and not seen any issues like this.

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Mon Mar 21, 2016 11:50 pm

Hallo,
ich habe mall das Programm Dependency Walker geladen und mir das mal damit die Sache angesehen es sind mir einige Dinge nicht ganz klar woher das kommt deswegen habe ich ihnen mal die Daten vom Programm gespeichert vielleicht können sie was damit anfangen.

Gruß
Thomas
Attachments
mLoader.zip
(938.21 KiB) Downloaded 91 times

User avatar
Benj
Matrix Staff
Posts: 12979
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 3740 times
Been thanked: 3595 times
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby Benj » Tue Mar 22, 2016 12:56 pm

Hallo Thomas,

Vielen Dank für das für uns tun .

Haben Sie Windows Update verwenden ? Wenn nicht, dann ist es wahrscheinlich lohnt sich sicher, dass Ihr Betriebssystem auf dem neuesten Stand . Wenn das nicht das Problem zu lösen , dann können Sie diese Microsoft Runtime- Pakete installieren. Wenn Sie ein zu einer Zeit und testen Sie mLoader tun , wie Sie gehen , dann wird dies uns helfen, zu wissen, welche Laufzeit für Sie das Problem behoben .

https://www.microsoft.com/en-gb/downloa ... x?id=48145
https://www.microsoft.com/en-us/downloa ... x?id=49984

Wir suchen auch in andere mögliche Ursachen des Problems aber es scheint, dass wir die erforderliche Bibliothek in mLoader selbst bauen, so dass das Problem seltsam.



Hello Thomas,

Many thanks for doing that for us.

Do you use Windows Update? If not then it's probably worth making sure your OS is up to date. If that doesn't solve the problem then you can install these Microsoft runtime packages. If you do one at a time and test mLoader as you go then this will help us to know which runtime fixed the issue for you.

https://www.microsoft.com/en-gb/downloa ... x?id=48145
https://www.microsoft.com/en-us/downloa ... x?id=49984

We are also looking into other potential causes of the problem however it appears that we build the required libraries into mLoader itself so the problem is strange.

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Tue Mar 22, 2016 11:36 pm

Hallo,
vor ab das alles hat nichts gebracht es geht immer noch nicht!

Was ich alles gemacht habe:

1 ) mein Betriebssystem ist immer auf dem neusten Stand!

2 ) ich habe das installiert was sie vorgeschlagen haben gemacht !

3 ) ich habe auch noch meine Voll Version von Visual C++ Aktuelle Version installiert!

4 ) ich habe auch noch mall etwas aus getestet wenn ich Bestimmte Dateien die das Programm laut Dependency Walker
nicht findet ( aber vorhanden im System ) in das Verzeichnis vom mLoader kopiere und das Programm Dependency Walker
nochmal gestartet um zusehen ob es einen Unterschied jetzt gibt da konnte einige Dateien gefunden die vorher nicht
gefunden worden genaues Ergebnis siehe Anhang.

5 ) ich habe auch verschiedene Analyse Programmen über mein PC (neuen) Laufen Lassen ob Fehler
auf meine System vorhanden sind es konnten keine gefunden werden!

Was ich immer noch nicht verstehe ist das der Alte Programmen EB006V8 vom Programm PPPv3.exe erkannt wird
aber nicht vom mLoader das gleich ist auch bei den Modulen ECIO diese werden auch vom Alten Programm erkannt aber
nicht von mLoader das ist was ich nicht verstehe das muss doch an der neuen Software Ligen mit den Zusammenspiel
von Win10 den mit Win7 geht es doch!

Bei meine Alten PC mit Win7 32/64Bit funktionier alles mit mLoader was ich aber fest gestellt habe das bei
Win7 (Alter PC CORE I5) einige Dateien da sind die bei eine neu gekauften PC mit Win10 64Bit ( Neuer PC CORE I7)
nicht vorhanden sind aber laut Dependency Walker für das Programm mLoader gebracht werden.

Diese sind aber auch nicht nach der Installation der verschiedenen Programme vorhanden!

Meine Vermutung kann das sein, wenn man von windows 7 auf windows 10 upgrade das dann die benötigten
Dateien dann noch vorhanden sind und bei einen neu gekauften PC fehlen?

Gruß
Thomas
Attachments
mLoader vom 23_03_2016.zip
(1.96 MiB) Downloaded 85 times

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Fri Mar 25, 2016 1:16 am

Hallo,
hier noch eine weitere Information für Sie!

Da ich jetzt langsam Komplet ratlos bin was das für ein Problem sein soll. :?

Habe ich mall meinen neun PC ( Typ Laptop HP Spectre x360 13t Touch Laptop) Komplet gelöscht und die komplette Software
inklusive Win10 neu Installiert mit der Hoffnung das es dann geht aber kein Erfolg gehabt es geht immer noch nicht!

Jetzt weiß ich nicht mehr weiter was es noch sein kann! :cry:

Ich hoffe das ihnen etwas einfällt.

Gruß
Thomas

EtsDriver
Valued Contributor
Valued Contributor
Posts: 383
Joined: Tue Apr 15, 2014 4:19 pm
Location: Kajaani, Finland
Has thanked: 319 times
Been thanked: 205 times
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby EtsDriver » Mon Mar 28, 2016 10:01 pm

Hei thomas, have you tried running windows 10 in unsigned driver mode and using older eb006 drivers? What anti-virus are you using and have you tried disabling it temporary?

-
Grüße aus Finnland!
Ill just keep the good work up!

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Sun Apr 10, 2016 11:43 pm

Hallo,

ich wollte mich mall wieder melden haben sie jetzt eine Lösung für das Problem bei mir
den des wäre langsam sehr nett, wenn ihnen jetzt etwas einfallen würde den mir fällt nichts
mehr ein was ich noch machen könnte meine mittel und Ideen sind erschöpft!

Den ich gehe davon aus das sie die Spezialisten sind wo die Software entworfen und Programmiert
haben und daher auch wissen müssten was das Problem sein kann!

Gruß
Thomas

Ps. Meine Einstellung zu der Software ist momentan nicht die beste und könnte sich aber noch verschlechtern, wenn wir keine Lösung finden. :evil:

User avatar
Rudi
Posts: 666
Joined: Mon Feb 10, 2014 4:59 am
Has thanked: 494 times
Been thanked: 188 times

Re: PICmicro multiprogrammer EB006V9

Postby Rudi » Mon Apr 11, 2016 4:35 pm

Hi Thomas
kurze Daten:
du hast..
- windows 10/64 bit
- multiprogrammer EB006V9 wird im Gerätemanager "richtig" erkannt und angezeigt
- der mloader findet jedoch den bootloader seit Umstellung/Neuinstallation Win 10/64 nicht mehr

Könntest du versuchen über den Gerätemanager mit Rechtsklick auf den multiprogrammer EB006V9 die PID und VID zu posten

Gerätemanager -> Rechtsklick auf multiprogrammer -> Eigenschaft -> Details -> Eigenschaft Hardware ID'S auswählen
die Werte posten einschliesslich der REV Nr.

Danke
lg
rudi ;-)

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Mon Apr 11, 2016 9:26 pm

Hi Rudi,

1) also das ist ein neuer Laptop 1 Monat Alt mit USB 3

2) der multiprogrammer EB006V9 und auch die Älteren Versionen werden richtig erkannt
da das Vorgänger Programm PPP beide findet und auch ansprechen kann.

3) Mit meinen alten Laptop Dell ( WIN 7 64 ) hatte ich keine Probleme

Hier die gewünschten Daten ich hoffe das du mir weiterhelfen kannst.

Gruß
Thomas
Attachments
EB006V8 Vorgänger.jpg
EB006V8 Vorgänger.jpg (33.28 KiB) Viewed 7741 times
EB006V9 .jpg
EB006V9 .jpg (40.74 KiB) Viewed 7741 times

User avatar
Rudi
Posts: 666
Joined: Mon Feb 10, 2014 4:59 am
Has thanked: 494 times
Been thanked: 188 times

Re: PICmicro multiprogrammer EB006V9

Postby Rudi » Tue Apr 12, 2016 10:45 am

@all
talk about first time in thomas language and after possible solution
then there is here a english "Summary for all".

Hi Thomas,

danke.

-mLoader Version 3.3.0.9
-Treiberversion 1.0.0.5 Treiberdatum 06.01.2015 für multiprogrammer EB006V9
-Flowcode V6.1.3.2 (18.02.2016) Professional-Version ( PIC/ AVR / dsPIC/PIC24 )
-außer dem erkennt die Software auch alle andern Programmer nicht
-dsPIC/PIC24 Multiprogrammer EB064
-PICmicro multiprogrammer Vorgänger Version
-und die ECIO Module ( 28 pin PIC 18 ECIO, 40 pin PIC 18 ECIO und 40 pin dsPIC 33 ECIO )
-für alle die Aktuellen Treiber installiert.
-Im Geräte Manager wird alles Richtig erkannt.

Kannst du noch mitteilen, wie du welche Software unter win 10/64 installierst hast?
Ich meine damit, bei der Installation von FC6 V6.1.3.2 (18.02.2016):
hast du diese Software frisch installiert oder auf ein vorhandenes FC6 installiert.
als Benutzer oder als Admin
Ich weiss, du hast alles noch einmal neu aufgesetzt und installiert, steht dir eine OEM Version von WIN10/64 zur Verfügung oder das Online ISO oder ein upgrade Berechtigung und du hast das Media Creation Tool verwendet. Das ISO dann für den berechtigten PC oder für ein anderen PC downgeloadet. Das ist jetzt ein entscheidenes Merkmal für die weiteren Schritte, denn bei der OEM ( DVD WIN 10 ) werden nicht alle Treiber und msvcrt... mitgeliefert. Du schreibst, das Win10 auf aktuellen Stand ist, das ist ok.
Eventuell stand dir eine Vorinstallation auf dem neuen Rechner zur Verfügung und eine Revovery Version über den Bootmanager. Die Infos fehlen noch Thomas oder ich habe es überlesen.

Der zweite Punkt wäre, wie du die Treiber installiert hast, durch die Installation von FC6 werden Treiber installiert.

Bei einer separeten Anwahl des offiziellen Treibers wie ihn dir Benj mitgeteilt hat, müsstest du diesen Treiber
- mit admin rechten installieren
- kompatiblen modus zu verwenden ( gerade bei 64 Bit ) immer sehr zu empfehlen da windows die Schwachstellen am Besten kennt und die richtige Vorwahl trifft
info1

letzteres heist, du müsstest die Installation darüber installieren.

Hinweis vorweg:

Wenn der Treiber zuvor ( normal ) installiert wurde , dann muss er komplett entfernt werden; denn wenn man den Treiber mit kompatiblen Modus darüber installiert, gelten die Rules erstmal aus der ersten Installation, und die lassen eine Kommunikation mit dem Treiber nicht zu; daher im Zweifel: Gerätemanager..rechtsklick auf das Gerät..Eigenschaft..Treiber entfernen und komplett neu installieren.
Um andere Probleme zu vermeiden (von den Sicherheitsaspekten ganz abgesehen) rate ich dringendst dazu, die Benutzerkontensteuerung (UAC) auf keinen Fall zu deaktivieren! Auch das Ändern von Sicherheitseinstellungen für das Installationsverzeichnis oder eine Installation in ein beschreibbares Verzeichnis ist nicht sinnvoll, da auch das Sicherheitsprobleme nach sich zieht.

Normalerweise wird das alles bei der Installation von FC berücksichtigt und selbständig so richtig installiert
wenn man die Installation mit Admin Rechten vornimmt und sich auch mit Admin Rechten freischalten lässt, heist auch, wenn Du einen normalen Benutzeraccount verwendest bei der Installation, fragt der Installer nach, dass Admin Rechte benötigt werden und du wirst zur Passwort Abfrage aufgefordert.
..

Jetzt warte ich noch deine Aussagen ab und werde mich dann danach nochmal die nächsten zwei drei Tage einschalten.
Normalerweise funltioniert das soweit alles tadellos Thomas, einige Sachen muss man noch händisch nachbessern ( UsbPicProgrammer) wenn man bei der Installation einen anderen Weg gegangen ist, aber es lässt sich nachbessern.

lg
rudi ;-)

EDIT1:
Nur um sicherzugehen, das Problem tritt bei diesen Programmer bei dir auf?

TFreund
Flowcode V4 User
Posts: 16
Joined: Mon Sep 14, 2009 11:30 am
Contact:

Re: PICmicro multiprogrammer EB006V9

Postby TFreund » Tue Apr 12, 2016 7:09 pm

Hallo Rudi,

also der Rechner war neu mit win 10/64 installiert.

Ich habe die Aktuelle Software Version mit Admin rechte installiert
( frisch installiert FC6 V6.1.3.2 //18.02.2016 ).

Es steht mir eine Revovery Version (Original von Hersteller HP) zu Verfügung auf meiner Festplatte und dies
habe ich auch verwendet bei der Neu Installation des Systems.

Die Treiber und alle andere Programme habe ich immer mit Admin Rechte installiert.

Wenn du möchtest dann können wir mall miteinander Telefonieren und das Problem zu
besprechen das wäre vielleicht einfacher?

Gruß
Thomas

User avatar
Rudi
Posts: 666
Joined: Mon Feb 10, 2014 4:59 am
Has thanked: 494 times
Been thanked: 188 times

Re: PICmicro multiprogrammer EB006V9

Postby Rudi » Sun Apr 17, 2016 10:10 pm

Hi Thomas,

kann beim besten Willen nicht feststellen, warum es nicht bei dir läuft.
Ich kann mich erinnern, ich hatte ein Problem bei WIN7/64 - da lief das nicht gleich.
Mein Fehler war, das ich wegen Cygwin die gross/kleinschreibung aktiviert habe. Das hatte ich dann wieder zurückgestellt, nach einem zweitversuch lief es dann. Die Treiber hatte ich separat nochmal installiert. Wobei du keine Probleme hattest bei WIN7/64.

Konntest du das WIN10/64 Problem schon lösen?
Aus welchen Ländereck kommst du?
Ich bin aus Niederbayern. Vieleicht ratschen(plaudern) wir mal?

lg
rudi ;-)